Sublime Forum

SFTP plugin stopped working

#1

Hi all.

Launching Sublime Text (version 4136) a message window shows up with this message (also written in the console panel):

The SFTP package seems to have been installed using an older version of Package Control. Please remove the SFTP package, upgrade Package Control to 2.0.0 and then reinstall SFTP.

It may be necessary to delete the “Packages/Package Control/” folder and then follow the instructions at https://packagecontrol.io/installation to properly upgrade Package Control.

Package control version is 3.4.1. Nonetheless I followed the instructions uninstalling Package Control from the command palette because I can’t find the “Packages/Package Control/” directory anywhere in my home directory.

After reinstalling Package Control and SFTP from the command palette I still get that error message; the SFTP plugin doesn’t work, none of its commands is available in the command palette.

I’m running licensed ST and SFTP plugin, Kubuntu 20.04.
I tried also ST versions 4135 and 4134.

What’s happening? How can I solve?
Thanks

0 Likes

#2

@wbond mentioned earlier in the Discord that there was something not set up correctly on his end when he built the packages, but it’s been resolved now so you should be able to upgrade (or remove and reinstall I would guess) to get it working again.

1 Like

#3

I just launched ST and everything was fine. Thanks!

1 Like