Sublime Forum

Setting VS Code as Editor on Ubuntu

#1

I was wondering if anyone has been successful in setting the editor preference for Sublime Merge to VS Code (or other editor other then Sublime Text)?

I’m on Ubuntu and installed VS Code via apt. I’ve tried setting the Sublime Merge editor value to /usr/bin/code, but that doesn’t appear to work as the menu option for opening in a editor then disappears.

I know it’ll be something silly…

Thanks.

0 Likes

#2

I’ve now also tried this on my Mac and have the same issue.

0 Likes

#3

You might need to change this topic to technical support. Also I don’t have an answer to your problem.

0 Likes

#4

Have done, Thanks @SHADOWELITE7

1 Like

#5

Your welcome

0 Likes

#6

I believe you need to specify the path to the actual executable within the .app bundle.

0 Likes

#7

Still no luck with this. For example I tried this "editor_path": "/Applications/Visual Studio Code.app/Contents/MacOS/Electron". The open in editor option just disappears, sad to say.

0 Likes

#8

Add this to Preferences.sublime.settings file: "editor_argument_format": "-g ${file}:${line}:${col}",

The Windows version shows this field in the “Advanced” tab in “Preferences” but not on macOS… Strange.

0 Likes

#9

I came back to this and used the preference setting like @johneo suggested. This appears to work when I go Sublime Merge -> Preferences -> edit settings. I used the binary path on my Mac machine /usr/local/bin/code.

However, the menu option for opening in editor (the one normally next to the reveal in Finder option, is still missing in action. Would be great to be able to do this to - as this is the main feature I want actually - I don’t mind one off settings menus opting in sublime, mainly want a shortcut to open my projects in my current editor of choice.

Thanks

0 Likes