Sublime Forum

Push to remote via https not recognized


I wasn’t able to push to Heroku over ssh just now, so I did it via https and that worked. However, I see that in Sublime Merge, that branch is still listed as being behind master. Does Sublme Merge not see https? Once I get things straight with Heroku, how do I get Sublime Merge to show the merge? Thanks.



Merge reads the state of the repository as it exists on disk and visualizes that, so the method (or program) that is making the changes should have no effect on what it sees so long as the repository has changed.

Does using Tools > Refresh or restarting Merge get it to see the state change?



Hi OdatNurd!
Thank you for your response.

  1. The answer is no, refresh did nothing for me.
  2. When I heard back from Heroku, I realized my mistake. Somehow (don’t ask me how, when, or why, 'cuz I don’t know) I had it in my head that the commands to push to Heroku for staging had to be different from the one for production. That is clearly wrong. I did the ‘normal’ push over ssh just now and was told ‘Everything up to date’ - because the https push over the weekend had already worked. So I’m good now, thanks - but:
    Please note that it was only after this successful ssh push that Sublime Merge moved my heroku/master repo up to where all the other branches are. So no, it appears Sublime Merge only sees / recognizes ssh pushes. I don’t know if that’s a bug or a feature, but that’s my experience.