Sublime Forum

Possible auto-complete / auto-expansion bug on Tab?


I’m noticing an issue in the latest version of Sublime-text where it appears to be ignoring my settings and auto-inserting text that I do not want when I press TAB in certain scenarios (despite having both "auto_complete": false and "tab_completion": false). I do not get the normal auto-complete drop-down menu, instead the text is just auto-expanded inline.

Edit: Also I did already see the post How to stop tab auto complete on 4126? and had originally replied there. But after realizing I could consistently recreate the issue and that mine was different in that it lacked the auto-complete menu shown in the other post, I decided to remove my debug info from that one and post as a separate topic since I believe they are similar but ultimately separate issues (e.g. I do not believe it to be a duplicate)

I am not entirely sure if this is a bug, a separate feature that does not currently have a preference tied to it, controlled by a different preference than I think it is, or something else.

Depending what is actually going on, my ask would be to either resolve the issue, request a setting to turn off the behavior, or if something already exists, just to clue me in on what I need to do to disable it.

System: Fedora 37, Cinnamon Spin

Sublime Version: Build 4143, Stable Channel (from Linux repo for Fedora, per here)

Is Licensed/Registered: Yes. I can verify on private channels; if needed, please specify correct contact method (email? etc) and I will be happy to do so.

Plugins: None (unless Sublime preinstalls some, in which whatever the defaults are)

User Settings:

  "always_prompt_for_file_reload": true,
  "atomic_save": true,
  "auto_close_tags": true,
  "auto_complete": false,
  "auto_match_enabled": false,
  "close_find_after_find_all": false,
  "close_find_after_replace_all": false,
  "color_scheme": "Packages/Color Scheme - Default/Monokai.sublime-color-scheme",
  "copy_with_empty_selection": false,
  "dark_theme": "Adaptive.sublime-theme",
  "drag_text": false,
  "ensure_newline_at_eof_on_save": true,
  "font_size": 15,
  "highlight_modified_tabs": true,
  "light_theme": "Default Dark.sublime-theme",
  "overlay_scroll_bars": "disabled",
  "show_encoding": true,
  "show_line_endings": true,
  "tab_completion": false,
  "theme": "Default Dark.sublime-theme",
  "translate_tabs_to_spaces": false,
  "trim_automatic_white_space": true,
  "trim_trailing_white_space_on_save": false,
  "update_check": false

User keybinds:

  // Unbinding keys:
  //    1. remove the command attribute
  //    2. set "command":"unbound"
  { "keys": ["ctrl+b"], "command": "unbound" },
  { "keys": ["ctrl+q"], "command": "unbound" },

  // Rebinds
  { "keys": ["ctrl+shift+d"], "command": "find_under_expand" },
  { "keys": ["ctrl+d"], "command": "duplicate_line" },

  { "keys": ["f9"], "command": "sort_lines", "args": {"case_sensitive": false} },
  { "keys": ["ctrl+f9"], "command": "sort_lines", "args": {"case_sensitive": true} },

  { "keys": ["ctrl+u"], "command": "upper_case" },
  { "keys": ["ctrl+l"], "command": "lower_case" }

Steps to recreate:

1. Open Sublime and create a new file and save it as somefilename.js (or set syntax to Javascript - I don’t actually need to save the file in order to recreate)

2. Add the following contents:

//	foo:

3. Place cursor on line 3, directly after the semi-colon

4. Press TAB key.

What currently happens:

text is automatically changed to:

//	fookey: "value", 

what is expected / what I would like to happen: nothing other than a literal tab character (\t) is inserted into text when I press TAB.

My goal is that Enter / Tab / Shift+<any letter/number/punctuation> NEVER triggers any sort of automatic insert / function and should instead just be regular typing. Instead, I prefer functions / any automatic things to happen when I use either F<1-12> keys or modifiers like Ctrl / Alt or via save events (I sometimes use "trim_trailing_white_space_on_save": true if I’m not going to be working with markdown files for a time where trailing space can sometimes be significant such as indicating an “empty line” in code blocks that use indentation). I mention this in case there are any other settings/ configurations / keybinds / etc that can be recommended that I should be setting… or other potential pitfalls that I should at least be aware of and know how to avoid in order to achieve my goal.

Thanks in advance
- Z