Sublime Forum

Plugin_host 3.3 and 3.8 has exited unexpectdely


You used the backslash before the at sign?

I think you might find that brew info openssl will point to openssl@3 3.2.0 or similar, and if you do a brew unlink openssl you will find that the 3.2.0 version will be unlinked (but not removed).



Yes, copied and pasted directly from your previous post: brew unlink openssl\@3

1brew info openssl` returns:

$ brew info openssl
==> openssl@3: stable 3.2.0
Cryptography and SSL/TLS Toolkit
/usr/local/Cellar/openssl/1.0.2q (1,794 files, 12.1MB)
  Poured from bottle on 2019-03-10 at 00:17:28
License: Apache-2.0
==> Dependencies
Required: ca-certificates ✘
==> Caveats
A CA file has been bootstrapped using certificates from the system
keychain. To add additional certificates, place .pem files in

and run
==> Analytics
install: 454,271 (30 days), 1,331,214 (90 days), 3,129,915 (365 days)
install-on-request: 65,579 (30 days), 186,657 (90 days), 512,899 (365 days)
build-error: 4,995 (30 days)

I then tried brew unlink openssl

$ brew unlink openssl
Unlinking /usr/local/Cellar/openssl@1.1/1.1.1q... 0 symlinks removed.

I then did brew info openssl again, and got the reame return as the previous time. :man_shrugging:

Seems weird that there’s no folder for openssl@3 in /usr/local/Cellar/ - only the two I listed before: openssl and openssl@1.1



that’s the default…

Does the Package Manager work now? Don’t forget to restart :-)-O



Unfortunately, I rebooted my system after this, and I’m still seeing the same error when launching Sublime Text, and package manager is still not working.

Just in case this may make a difference, here are my specs:

Hardware Configuration:
  Model Name:					MacBook Pro
  Model Identifier:				MacBookPro14,3
  Processor Name:				Intel Core i7
  Processor Speed:				2.9 GHz
  Number of Processors:			1
  Total Number of Cores:		4
  L2 Cache (per Core):			256 KB
  L3 Cache:						8 MB
  Memory:						16 GB
  Boot ROM Version:				185.0.0
  SMC Version (system):			2.45f0

System Software Overview:
  System Version:				macOS 10.12.6 (16G29)
  Kernel Version:				Darwin 16.7.0
  Boot Volume:					OSX
  Boot Mode:					Normal
  Secure Virtual Memory:		Enabled
  System Integrity Protection:	Enabled

  Terminal app:					Version 2.7.3 (388.1.1)


I happen to use the same macos version (Sierra) and I also had this problem. What worked for me was replacing my package control with beta9 (Package Control 4.0.0-beta9) and disabling automatic updates for it by editing Package Control.sublime-settings (“auto_upgrade_ignore”: [“Package Control”]). For whatever reason package control versions > beta9 don’t work for me.

1 Like


Even not 4.0.0-beta10?

Final release 4.0.0 ships with latest asn1crypto and oscrypto libraries from as they seem to ship relevant changes for latest MacOS builts and arm64 architectures. Those are therefore the most likely ones to blame, if beta10 still works.

If someone can verify beta10 to work, we could revert oscrypto to 1.3.0 release to see if it helps. Otherwise I can only drop that downloader completely as there seems rather low progress with that libraries, recently.



I just checked again to make sure. Yes, beta10 crashes on me, beta9 is the last one that works. Here are my debug logs for beta9 and beta10.




There are some changes between beta9 and 10 but nothing obvious, which could cause plugin_host to crash. As everything is running fine on my Windows boxes a MacOS user suffering from it, would need to do a bisect between those two tags to find the commit, which introduces the problem.

Otherwise running ST via a debugger could probably reveal a traceback to help sublimehq to narrow the reason down.

Without someone pointing to the reason I doubt I can do something to resolve this issue.



I tried as you suggested, and was seeing an additional error:

Error trying to parse settings: Expected value in Packages/User/Package Control.sublime-settings:6:2

Discovered it was occurring due to the string you shared having “smart” quotes (just realized this forum does this, which I guess highlights the importance of using code formatting):

“auto_upgrade_ignore”: [“Package Control”]

Changing this to the following resolved the error:

"auto_upgrade_ignore": ["Package Control"],



Terribly sorry about formatting, that was my first time posting on these forums. From your post it’s unclear whether your original problem was resolved. If it’s still there, now that you have successfully disabled auto updates for Package Control try repeating step 1 (installing beta9 again) since it’s most likely been updated to the latest version as a result of Sublime Text not recognizing the line with smart quotes.

1 Like


Yes, I had to do it as you’ve mentioned, quitting sublime text, and replacing the package control file again. I also locked the file through the get info UI to make doubly sure that it won’t be updated.

I was encountering an unusual problem after resolving this, however. a custom color scheme file (tmTheme) that I had been using for a particular file format /syntax for quite some time was failing to load. I ensured that the path listed in the syntax settings file was correct. and there didn’t appear to be anything wrong or changed with the file itself since 2022.

after trying a different custom color scheme (with the tmTheme file located in my packages/user folder), I noticed that it worked okay. after moving the problematic scheme file from the packages/ReaSyntax folder to the user folder, and correcting the path in the syntax settings, it loads okay.

I’m not sure why it would no longer load from a different folder in the packages folder other than the user folder as a result of this package control update. but maybe that will lend a clue as to to what might be causing the main plugin host error here.

But for now, everything seems to be working properly again for me. So thank you for your help!

And no worries about the formatting. I didn’t know it would replace straight quotes with smart quotes either until I was replying to your post and noticed it happened, then edited my response to use code formatting to ensure it wouldn’t replace the quotes.

1 Like


Is that other package (ReaSyntax) in your list of ignored_packages in your user preferences?



No, ReaSyntax wasn’t in ignored_packages to my knowledge. I think the issue with it just had something to do with some customizations I made to that package in particular.

But now, just like that, it’s doing it again. :sob:

The “plugin_host 3.8 has exited unexpectedly” error is back. The Package Control.sublime-package file is still locked and unmodified since Jan 17. Still the same 4.0.0-beta9 version. Not sure wtf is causing it to crash now, but getting really annoyed with this issue.



Could you try Package Control 4.0.3, please? It ships some changes to prevent possible race conditions with setting up openssl library at startup and reduces oscrypto usage on MacOS and Linux, which could possibly help. I am unable to find any evidence about what otherwise might cause releases after beta9 to cause such issues. They may be related with possible API changes on OS level, which may require update of oscrypto library, but if so - good luck.

1 Like


Looks like 4.0.5 is the latest. I’ll try that first, assuming you suggested 4.0.3 because it was the latest at the time of your last message.

Thanks again!

UPDATE: I tried with 4.0.3 and 4.0.5, and I’m still seeing the plugin_host-3.8 crash/error a few seconds after loading ST with either version.

In case it might help troubleshooting this, here’s what I have in my Packages/User/Package Control.sublime-settings now:

		"Package Control"
	"bootstrapped": true,
		"1337 Color Scheme",
		"AppleScript Extensions",
		"BBCode Syntax",
		"Color Highlight",
		"Color Scheme - Rainbow",
		"Darkula Color Scheme",
		"Default File Type",
		"Dotfiles Syntax Highlighting",
		"Dracula Color Scheme",
		"GitHub Markdown Snippets",
		"Hex to HSL Color Converter",
		"Homebrew Build System",
		"Indent XML",
		"KSP (Kontakt Script Processor)",
		"Man Page Support",
		"Old-Style ASCII Property Lists",
		"Package Control",
		"Package Syncing",
		"Plist Binary",
		"Sync Settings",
		"Theme - Darkmatter",
		"Zip Browser",


Okay I had a hunch it might have something to do with the “rainbow_csv” package. So I tried moving that back into the installed packages list, saving, and restarting. It seems to have loaded up with just some warnings about theme issues.


After this, I tried checking a csv file to see if the rainbow_csv theme was still working, and it wasn’t. I then tried using package control to remove and reinstall that theme. But shortly after I chose to remove it from the command palette, the plugin_host crash occurred again.

I’m not sure how this works, or why it’s happening. but hopefully this info might help someone figure it out.

UPDATE: I’m a little nervous that saying this might jinx it, but I think I fixed it! I searched my system for instances of “rainbow_csv”, and ended up deleting the folders I found in both the Packages and Cache folders, then deleted it from the Package Control.sublime-settings file in text edit, then launched ST again (no plugin issues), then installed the rainbow_csv package again from the command palette (still no plugin issues). So hopefully this is resolved for good now, and the only thing left to figure out is how to restore the theme colors for the side bar (which has reverted to a default black on white).



I don’t see a “rainbow_csv” package, but I can install and run ST with PC 4.0.5 without issues, with all the packages provided by your settings file. Still no crashes on ST4169 & Win11.

Removing a packages,

  1. adds it to “ignored_packages” to disable it,
  2. deletes related Installed Packages/.sublime-package file,
  3. the unpacked Packages/ folder, if present
  4. the package cache Cache/ if present
  5. and finally any pre-compiled plugin from Cache/__pycache__/…

all of which are normal filesystem operations. Those causing plugin host to crash indicates rather serious OS related runtime issues, a python plugin barly can workaround, I guess.



These issues have specifically been occurring on macOS (10.12.6 Sierra). I don’t have any issues on PC.

The most recent issue now is with AutoSpell not working. Tried removing it, but maybe since it is an unpacked plugin, it threw the plugin_host error, and I had to do the manual removal process.

After removing it manually and reinstalling it via command palette, I still can’t seem to get it to work on my Mac now. Still works okay on PC, though.

UPDATE: I got AutoSpell working again! However, for some reason, despite having a Tab character listed as one of the default triggers in my user settings for the package (AutoSpell.sublime-settings), it doesn’t work to trigger the replacement text. Maybe this is due to the Tab key having some other function in sublime text (e.g. the autocomplete list popup trigger). but using " " or “enter” in default triggers works to enter the replacement text when hitting space or enter.