Sublime Forum

Package Control Testing


I’m very near to rolling out Package Control version 3.4.0. I’d like some assistance in testing.

This release will be the last to support any version of Sublime Text older than 3.0 (build 3143).

Some notable changes:

  • Fix for compatibility with macOS 11 Big Sur
  • Support for hosting packages on
  • Properly respecting the “default branch” on GitHub, rather than assuming master
  • Support for the side-by-side setting window

I’d like help in testing any version of Sublime Text you’ve got installed. Ideally testing would involve an upgrade from a previous version. To do so, please:

  • Run the “Add Repository” command from the command palette
  • Enter the URL:
  • Open the Package Control user settings via Preference > Package Settings > Package Control > Settings - User.
  • Add the setting: "install_prereleases": ["Package Control"],
  • Use the command palette and run “Upgrade Package”

Please look out for Python errors in the console, anything not functionality properly, or any other sort of issues you may find. Please report issues at

Thank you for the help!



For users running the macOS 11 Big Sur beta:

Since the current version of Package Control won’t work for you, you’ll have to perform some manual steps.

  1. Open the Sublime Text console
  2. Paste sublime.installed_packages_path() into the input and press enter
  3. Copy the output, including quotes. It should look something like '/Users/USERNAME/Library/Application Support/Sublime Text 3/Installed Packages'.
  4. Open
  5. Change the directory to the path you just copied by typing cd then space, pasting the installed packages path.
  6. Execute pwd and make sure you are in a directory named “Installed Packages”.
  7. Run curl -O " Control.sublime-package"
  8. Restart Sublime Text
1 Like

Package Control fails to load on fresh install OS X

When I do this, I Package Control seems to work again, although two exceptions are thrown when Sublime Text opens:

reloading plugin Man Page Support.new_page
Traceback (most recent call last):
  File "/Applications/Sublime", line 125, in reload_plugin
    m = importlib.import_module(modulename)
  File "./python3.3/importlib/", line 90, in import_module
  File "<frozen importlib._bootstrap>", line 1584, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1565, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1532, in _find_and_load_unlocked
  File "/Applications/Sublime", line 1199, in load_module
    exec(compile(source, source_path, 'exec'), mod.__dict__)
  File "/Users/zachriggle/Library/Application Support/Sublime Text 3/Installed Packages/Man Page Support.sublime-package/", line 5, in <module>
ImportError: No module named 'sublime_lib'


Package Control: Moving HTTP cache data into "Cache/Package Control/http_cache/"
Traceback (most recent call last):
  File "/Applications/Sublime", line 298, in on_api_ready
  File "/Users/zachriggle/Library/Application Support/Sublime Text 3/Packages/User/", line 12, in plugin_loaded
NameError: global name 'expand_settings' is not defined


Forgot to add a link to the full log, and I can’t edit the above post so here’s the full log:



Thanks for testing @ebeip90. Both of the errors you highlighted appear to be with third-party packages and aren’t due to Package Control.



Installed PC normally via menu on ST 3143 vanilla setup and upgraded to 3.4.0-rc afterwards without issues on Windows 10 x64 2004.

Then removed the local Package Control repo from my normal ST4 install and continued installing via menu and upgrading with all packages kept installed as is. Worked fine as well.

Note: I am using portable setups with Data dir directly in ST installation folder.



These instructions worked for me on the Big Sur beta! Thanks



Looks like no dependencies are available, currently. Maybe a crawler issue as no references can be found in the downloaded json files.

With another query 20min later dependencies are back again.