Sublime Forum

Package control not working


I have downloaded Sublime 3(unregistered, portable) and added package control.
I now press ctrl-shift-p and type install and choose package control: install package and then trying to select anything.
The window closes asnd nothing happens.
I have tried cobol syntax, pl/sql syntax and sublimerge pro and nothing… tried some random stuff and nothing…
What am i doing wrong?

Traceback (most recent call last): File "package_control.package_installer in C:\Programi\Sublime\Packages\Package Control.sublime-package", line 159, in on_done File "package_control.package_disabler in C:\Programi\Sublime\Packages\Package Control.sublime-package", line 74, in disable_packages ImportError: No module named 'package_control'

1 Like



Oops, better reinstall everything, as it says “No module named ‘package_control’”. I you just installed Package Control, I guess you may be starting with Sublime Text, so you may don’t mind to remove all of the user data, to be sure to restart from a clean place. See:

Then, for Package Control installation, use this site: . Personally, I opted for the manual install. If something seems to go wrong during install, this may tell more.

Otherwise, the error posted can’t tell why Package Control seems to not be installed.

1 Like


I managed to repair it. The plugin was in the wrong folder. It should have been in Installed Packages, not Packages.
Thank you!

1 Like