Sublime Forum

Package Control error after moving to Apple Silicon Mac


I used Migration Assistant to move my files and apps over from an Intel-based Mac to a MacBook Pro with the M1 Max chip. Since doing so, when I start Sublime Text (Build 4122) I get the following error in a dialog.

Package Control

Error executing: /usr/bin/git symbolic-ref -q HEAD

Working directory: /Users/gray/Library/Application Support/Sublime Text 3/Packages/Package Control

xcrun: error: unable to load libxcrun (dlopen(/Library/Developer/CommandLineTools/usr/lib/libxcrun.dylib, 0x0005): tried: ‘/Library/Developer/CommandLineTools/usr/lib/libxcrun.dylib’ (mach-o file, but is an incompatible architecture (have ‘x86_64’, need ‘arm64e’)), ‘/usr/lib/libxcrun.dylib’ (no such file)).

VCS-based packages can be ignored by changing the “ignore_vcs_packages” setting to true.

Sublime Text will need to be restarted once the setting is changed.

I assume this is a problem—is it?. It tells me how to make the message go away, bit how do I fix it?

Thank you!



Sounds like it’s running ST under rosetta but possibly without rosetta installed, or something along those lines. I’d suggest simply reinstalling the application as ST has native arm support.



I was already running the universal version, but I downloaded Build 4121 and overwrote Build 4122 to see what happens. When I launch ST, the same error appeared.



Did you use Finder to extract and override the currently installed application?



Yes, I did. That is the only way to install it, no?



This seems to be a common problem:



Interesting. I searched for that error before my original post and did not see that post.

I was able to fix the problem by reinstalling Xcode Command Line Tools. I had them installed them before moving to the new machine, but as the error states, they were x86_64 based tools and not arm64e. In case anyone else runs into this issue, you can remove the old tools with:

sudo rm -rf /Library/Developer/CommandLineTools

and then you can reinstall the tools with the proper architecture using:

xcode-select --install