Sublime Forum

OS X Control-Space not working

#1

I’m trying to use the trial version of build 2097 on OS X 10.6.8. I cannot get the keyboard shortcut for auto-complete which is ^SPACE to work.
Any ideas?

Thanks, Rick

0 Likes

#2

It’s possible ctrl+space is intercepted before it gets to the application. For example, it’s possible to have ctrl+space interact with Spaces.

Rather than digging around in your system settings, it may be simpler to just rebind it to another key.

0 Likes

#3

Control-Space is reserved by OS X for changing keyboard layouts. Unintuitively, you have to enable the feature to disable the keyboard shortcut (and free up the key combo). To do this:

  • Go to System Preferences > Language & Text > Input Sources

  • Check (turn on) at least two input sources in the left column

  • Click the “Keyboard Shortcuts…” button in the right column

  • Select Keyboard & Text Input on the left

  • Scroll to the bottom and disable “Select the previous input source – ^Space” on the right

  • Go back to System Preferences > Language & Text > Input Sources

  • Turn off the inputs on the left

1 Like