Sublime Forum

New Package not showing up in Package Control


I’m the author of which was accepted into Package Control about a week ago. I’m not seeing it appear however in Package Installer. I have tried a fresh installation to be sure. Anything that may be missing from the submission/package or any suggestions?



All of the tags in your repository have an -alpha suffix on them marking them as a pre-release. Package Control won’t offer prerelease packages for installation unless they’re in the install_prereleases setting in your Package Control.sublime-settings file.

Tagging an official release and waiting for the crawler to notice the new tag should clear up the issue, if you have an official release ready.



Thank you for your reply and your help. I tagged an official release (no -alpha) and it appears it has been crawled, since I also updated the README and that is reflected on, but still not visible in Package Control within Sublime Text. Enabling the package in install_prereleases, the version it offers is 0.1.16-alpha, from over a year ago, that was never accepted for merge into Package Control. There seems to be a step I am missing.



Your git tag is not a semver:

You tagged it as 1.01, but I’m assuming you meant it to be 1.0.1

Just make a new release with tag 1.0.1 and it should be fine.