Sublime Forum

Mac Sublime CFML Plugin cannot type close caret >



I just started using Sublime on my Mac, OS Monterey 12.3.

First thing I installed was the CFML plugin and tried to create and edit a *.cfm file.

To my surprise, Sublime will not accept the keystroke to enter a closing caret at the end of a tag. In fact with the plugin installed and while editing a ColdFusion file, the > character cannot be entered from the keyboard at all!

Cut and paste, no problem. i have tried using a different keyboard without success, and once again, other file types, or with the CFML plugin uninstalled, the close caret works fine.

Any assistance is gratefully accepted – I am simply trying to do my work, and have settled on Sublime with the CFML plugin as the best option.


  • jonku


Sounds like there is an issue with that particular package.

A first step in troubleshooting what’s happening would be:

  • Open the Sublime console via View > Show Console
  • Enter sublime.log_commands(True) to turn on command logging
  • Enter sublime.log_input(True) to turn on input logging
  • Switch to a file and try to press that key to close a tag and see what (if anything) is printed

The input logging will tell you when Sublime sees you pressing a character, what happens. The command logging will tell you what the key actually does, if anything.

From the sounds of the problem you’re having, the plugin has tried to bind a custom command to that key to take an action, but it doesn’t do what it’s supposed to, and the input gets eaten. The log saying what it’s trying to do is a step towards determining what went wrong.



Thanks a ton for your response.

As it turns out, I went today to see if I could add or edit a key binding and it works now. I don’t think I took any specific action, but at least I can work and stop looking for another IDE.

This issue no longer occurs.

  • Jon
1 Like


I see various exceptions in console when editing CFML files. Maybe those are related.

Filing an issue at might inform maintainers about it.