Sublime Forum

LSP not showing in Status bar


I have a problem with LSP. A day ago everything worked fine, lsp was showing on my status bar and now all of a sudden it stopped showing, when I press command + shift + p to open a command pallet there is no more enable/disable language in project or globally which used to be with LSP, does anybody know what is going on here?



Open Preferences: Package Control Settings

is LSP in the ignored_packages or in_process_packages key ?



Yeah it wasn’t in ignored, I reoppened sublime a few times and somehow it worked, no idea why it happened in the first place. Thanks for the help tho.



That happens to me quite often as well. It seems that package control just locks up when loading all my packages, and most often it seems to lock up at loading LSP. I’ve played with removing and disabling various packages to no avail, but as you noticed, a restart usually works. This only happens on Windows 10 though. Linux and my Chromebook have no problems with the same plugins. Anyway, I just live with it. It’s just one more reason to abandon Windows permanently.

1 Like


Yeah I am using mac m1 air, happens there too sometimes, but I still find my mac to be amazing for programming so I can’t complain. restard usually fixes it, that is the only fix I have found out working at the moment.



Turn on Package Control debugging: Preferences -> Package Settings -> Package Control -> Settings. Add “debug”: true

Ctrl-~ opens the console and you can see where it hangs.

But it works after restart, so I won’t worry about it. Even if I have to restart 2 or 3 times to get it to work, it still loads faster than any other IDE.



Thanks for the additional info didn’t know about this. Yeah sublime is definietly fast, sometimes it freezes or something like that, feel like it’s not fully optimized but also that could be due to the plugins I have, takes some time to load everything and all that. Still prefer it over any other editor/IDE. Sublime ftw :smile: