Sublime Forum

Long lockups when using remote file systems

#1

Whenever the project is on a remote file system, (nfs, sshfs, etc) there are long lockups when doing anything inside the editor.

For example pressing a few keys on the keyboard or changing a file and sublime text 3 would freeze for a few seconds.

This behavior is NOT present using Sublime Text 2, this is strictly a sublime text 3 issue. But sublime text 2 has a bunch of its own annoying bugs, making it not a good replacement for 3.

I tried to disable index_files but it does not help.

My best guess is sublime text 3 indexes every file, very often (any keypress / file switch), in a blocking way thus locking up everything until its done. And sublime text 2 works because it never indexes files, or indexes them non-blocking/off the main thread.

Does anyone know a solution?

0 Likes

#2

most reports I have seen seem related to the sidebar file list taking a while to update, as opposed to a slow editor in general:


although there was an old issue relating to saving when atomic save was the default:

it seems unlikely that it would be related to indexing if it happens while you type, because it will index the buffer, not the document on disk/remote FS. Have you tried with no third party plugins installed?

you may find that build 3142 fixes some performance issues (compared to 3126) as it had a big rewrite of some FS handling code

0 Likes

#3

I will try 3142, I tested with no plugins sublime text 2 and sublime text 3. 2 works amazing, 3 locks up the whole editor for seconds at a time very frequently.

This issue is very easy to reproduce on linux, its happened to me on Debian, ubuntu, fedora and arch so definitely im not the only one with this issue. Just sshfs a folder from your cloud server, and open it using “open folder” then try to type/save/edit/switch a file.

Also using inotify-tools to check the folder for events, sublime text 3 triggers a crapload of reads, it literary reads/accesses every file in the root down every 30 seconds or something in a blocking way. Sublime text 2 does not exhibit this behavior.

I think there might be code in the core like this:
----for file in files:
--------ts = blocking_access(file)
--------if ts != cached_ts do file_changed(file)
And on remote file systems, that blocking_access is very latency dependent.

0 Likes

#4

potentially related:

0 Likes

#5

I just tried the latest release. The issue is still there and it has not been improved. Same long freezes to the main GUI.

0 Likes

#6

That’s correct, there hasn’t been any work on this issue recently.

0 Likes

#7

This issue is a really big bug.

The thread it blocks is so deep in the core that, if your remote file system gets any kind of network hangs, ALL your sublime texts that you have open freeze.

0 Likes

#10

Any news on this issue?

0 Likes

#11

Just tested latest version still same problem. Even under low latency, long lockups using sshfs.

0 Likes

#12

I have not spent time on this yet.

0 Likes

#13

Im not sure why its indexing and reading content from every file so often but another issue is its probably using file event subscriptions (inotify/fsevent/etc) and those dont work on remote file systems like sshfs. So if you create the file remotely, your OS sees it, ls /remote_mount, but sublime_text wont.

An option to disable the reading/indexing of every file would help tremendously, I never use those features anyways like Go to definition. (sublime text 2 never indexed/read all files like ST3 does and does not suffer from this issue, but sublime text 2 has other bugs that make it not feasible to use)

0 Likes

#14

You can disable indexing by setting index_files to false. I’m not sure if the sidebar will still be updated regularly, but I expect it to make an initial crawl to fill goto anything at least.

0 Likes

#15

Yes you can, but it does not make the lockups go away. No noticeable changes. Iv scoured all the options numerous times and disabled all plugins.

0 Likes

#16

Hey there,
this bug has been affecting my current workflow a lot ( I only work remotely ). However, I love sublime over any other editor, so I checked if there is something that could temporarily help.
After reading trough the post in https://github.com/SublimeTextIssues/Core/issues/1195 I tried to simply not open a folder, but rather only a specific file.
Indeed in my case, only opening single files instead of a folder (no project in the sidebar) helps to alleviate the problem somewhat.
Just for reference:

  • Opening a folder, which contains a single file inside leads to tremendous lags while editing (e.g. adding new lines, writing anything). Completely unusable for any serious - more than a line - editing
  • Opening the same file as before, but only the file, not a folder - Normal speed, no lags whatsoever.

Of course, if you need to remotely open a whole project … thats another story.

EDIT:

I didn’t make it very clear that I am mostly using Python as my language, whereas I use the anaconda extension for syntax completion etc. Since this extension is really a heavyweight, disabling it turned everything back to normal. Anyone else did use a certain plugin ?

0 Likes

#17

Using remote filesystems in Sublime is still a horrendous experience, 3 years after this was first reported.

0 Likes