Sublime Forum

Latex Sync


Dear Sublime Team,

I am experiencing an annoying lack of synchronization when compiling with latex (system: MacOS Mojave).

Specifically, when inside e.g., the proof of a theorem, the default PDF viewer (Skim) goes at the beginning of the section instead of staying focused on the specific part that I am changing.

My current flags inside the LatexTool Settings are as follows:

"keep_focus": false,
// Sync PDF to current editor position after building (true) or not
"forward_sync": true,

// Set this to false to disable the overwriting of the goto overlay for the hotkey `C-r` and `C-shift-r`
// You can still access the "table of content quickpanel" via `C-l, C-r` and  `C-shift-l, C-r`
"overwrite_goto_overlay": true,

What should I do to remove this annoying trouble?

Thanks in advance



It’s probably worth asking this on the LatexTools repository, as this is a plugin developed by the community not by the Sublime HQ team.