Sublime Forum

How to turn off Line Numbers

#1

Using version 3 3143
I can’t seem to find a way to turn off Line Numbering.
Please Help
Thanks
Dan

1 Like

#2

There is a preference for this:

// Set to false to prevent line numbers being drawn in the gutter
"line_numbers": false,
0 Likes

#3

I found “line_numbers”: false

It already exists in Default Settings and yet I still have line numbers showing in text files along the left edge of the screen.

Perhaps the “line_numbers”: false would be best off in a different config file?
Other than that I don’t know what to do, any ideas?

Thanks
Dan

0 Likes

#4

I just tried this out on my own setup and it seems to work. Here are the steps I took:

  1. Open Sublime
  2. Under Preferences select Settings. This will open a new window with two panels. On the left is the default settings. On the right is your personal preferences.
  3. Add "line_numbers": false to the personal preferences file. If you have several preferences already written, be sure to manage the commas at the end of the JSON entries.
  4. Save the file. The line numbers should immediately disappear.

I’m not sure you can edit the Default preferences directly though you might be able to with Package Resource Viewer. Applying changes to your own User settings is the most appropriate way to accomplish the change.

0 Likes

#5

Thanks, I did as you suggested, tried to save the file, got a parsing error.
Its becoming more trouble than its worth, so I’m thinking to just uninstall the program
Thanks
Dan

0 Likes

#6

Parsing was probably just because of commas. I’m sure we can sort this. Maybe post what you put into the settings file and we can spot a syntax error. You can do what you like though this should be a pretty simple fix. If your settings is only that one setting, then try

{
    "line_numbers": false
}
0 Likes

#7

Remi, I’m not sure your suggestion is correct.
danost, are you using Sublime for Windows or Mac?

I have sublime Version 3.2.2, Build 3211 on my windows laptop at work and the solution suggested by Remi works fine.

At home I have sublime (will have to wait until I get home to check the Version / Build numbers), and I get the same problem you are having.

Will try again when I get home and report the results back here.

0 Likes