Sublime Forum

How to disable "Definitions: .." popup in code

#1

I am not sure this if this was from a recent update to ST or a plugin, I have removed all things like CodeIntel and still it appears. It’s annoying as there is a hang before the definition loads:

2 Likes

#2
3 Likes

#3

amazing, thank you! couldn’t find this answer anywhere

0 Likes

#4

I definitely recommend checking out the default settings and key bindings a few times to get a sense of what is available and configurable.

3 Likes

#5

Related to this, I have the opposite problem. If you have another package that shows popups on hover(for me LSP), it this popup won’t be shown. Is there a way to tie the on_hover event to a key modifier such as ctrl or shift, so that I can set a context and have both kinds of popup?

0 Likes

#6

Currently, no. The Show Definitions and Show References are available via f12 and shift+f12, although they use the quick panel instead of a popup since they are designed for keyboard interaction.

0 Likes

#7

Thanks. Show Definitions in quick panel is maybe more useful so I’ll use that.

0 Likes

#8

We can set "show_definitions": false in user settings. It worked for me.

1 Like