Sublime Forum

Help -- I can't type!

#1

Somehow with the latest Dev 2099, I accidentally got into a mode where the blinking caret turned into a blinking underscore. This is on OS X. It said “command mode” in the status bar… I quit ST and restarted, and still the underscore was present, and it would not allow me to type anything! I’m sure I’m an idiot, but I don’t know how to get out of this mode.

0 Likes

#2

Sounds like you’re in vintage mode. Open up your Global.sublime-settings (in another text editor, if necessary) and put this in there:

“ignored_packages”: “Vintage”]

I think “v” quits that mode, too.

0 Likes

#3

There is no other indication that I’m in that mode, other than I can’t type and the _ cursor. I have used VIM a long time ago, and I remember typing “ESC” then :q to quit. But I can’t seem to do that either. I moved the Vintage package to an ignored_packages folder, restarted sublime, and still no luck. :angry:

Another strange thing: if i open a new file, i can type, but if I try to type in any of the files which were already open in my project, it doesn’t work. I’m wondering if this is a bug? I’m using the latest 2100 release on OS X.

0 Likes

#4

I experienced this same thing around the time Vintage came out—if you just close all your buffers and reopen them you should be good to go. I haven’t seen the problem since.

0 Likes

#5

Eugh, I got bitten by this today. Closing all files works, but still annoying. It happened at startup for me, hot exit didn’t help. Not really sure what other info I can give you.

0 Likes

#6

Also got bit by this today. Haven’t closed out all buffers yet, but a quit + edit “Global.sublime-settings” + starting ST2 at least lets me edit (thought the cursor still looks wrong).

0 Likes

#7

Just to be clear, for everyone who’s had this, have you changed your ignored_packages setting (at any time) to enable Vintage?

0 Likes

#8

I’ve only experienced it on Windows, and I enabled and disabled Vintage to fix it. It ended up happening a few times while I was running ST2 on Windows, but I only really do that for testing. I have not experienced it at all on Linux.

0 Likes

#9

Yea, I accidentally downgraded to 2091 today (it was early), so I think it still had the vintage package there, but it wasn’t disabled. I quickly reran my script, updated to 2101. Unfortunately this didn’t fix the problem. I checked global settings and it still had Vintage as being ignored. I tried a few things, but ultimately, I had to do a ‘real’ exit and reopen sublime. I tried reopening the project / switching projects, and it had the same effect.

My guess is maybe there is a flag in sublime that says hey im in vintage mode. When I opened 2091, it loaded vintage, that was set. I did a hot exit and that was saved somewhere. I reopened 2101 and that flag was still there?

0 Likes

#10

Yeah, I had enabled Vintage for a little to try it out. I turned it back off and that’s when the problem happened. Maybe the views got stuck in ro mode because I was in command mode when I turned Vintage off?

0 Likes

#11

When Vintage is enabled, it’ll set the command_mode and inverse_caret_state settings on all views. When it’s disabled, it removes these settings. However, if it doesn’t get notified about being disabled, such as via Global.sublime-settings being modified when Sublime Text isn’t running, then the settings will be left around.

I’ll take a look at changing things such that these settings are never serialized.

0 Likes

#12

I did not enable VI mode intentionally, and afterwards moved the package to the ignored packages folder, and even that didn’t help. It is still not clear to me how I got in VI mode. What is the keystroke to enter/leave vintage mode? I didn’t see anything in the key bindings.

0 Likes

#13

Temporary solution:

  1. Save and close the project
  2. Edit the project file
  3. Replace “command_mode”: true with “command_mode”: false
  4. Replace “inverse_caret_state”: true with “inverse_caret_state”: false
  5. Save the file
  6. Reopen the project
0 Likes

#14

I experience this problem today on Lion.

Closing all buffers, quitting and then re-opening sorted it.

I don’t remember ever enabling Vintage mode.

0 Likes

#15

Had this problem in the year 2022 except that caret is not an underline. Closing Sublime Text and restarting re-enabled typing. This is Build 4126, running in Windows 10. If this is Vintage mode there seems to be no key press for entering Insert mode.

0 Likes