Sublime Forum

Gpg failed to sign the data



i’m currently trying the latest unregistred version of Sublime Merge (Stable build 2059) on Windows 10.
Repository setup and pulling works fine as expected.

The only problem that occurs is this:

When i try to commit something this error appears.
I don’t want to rule out a mistake on my part, but it works fine when tested with Sourcetree. In this case the pinentry dialog prompt me for the key-password.

Or might it be a bug in Sublime Merge because it works fine with other tools with default settings?

Thanks in advance and best regards!



Which GPG do you have installed?

1 Like


Thank you very much for this hint!

After some further research i found out, i never installed GPG manually. Instead i used the “git-shipped” version of it (2.2.29-unknown).

I had to set the “gpg.programm” within git config:
git config --global gpg.program "/c/Program Files/Git/usr/bin/gpg.exe"

Now it works fine! :slight_smile:



It’s also possible changing Preferences > Advanced > Git Binary to system would have fixed it (since SM doesn’t ship GPG with bundled git).

1 Like