Sublime Forum

Getting SublimeText back to respecting my system wide hotkeys

#1

Since a few days or maybe a week, SublimeText does not respect my system-wide hotkeys on Linux anymore. Specifically, I use the context menu button to display a Guake Terminal. This has worked perfectly until now. When I press the context menu key, SublimeText will display a context menu. All other applicatons on my system still respect my hotkey, so I figure the cause of the problem lies in a recent change in SublimeText.

I have tried different options to change the key binding for the menu key, using Preferences -> Keybindings. eg:
{ "keys": ["context_menu"], "command": "noop" },
{ "keys": ["context_menu"], "command": "unbound" },
{ "keys": ["context_menu"] },
But to no avail. In case of the first 2 attempts, it will do nothing when I press the menu key. So my setting definitely has an effect, albeit not the desired one.

I found a few posts on this topic, eg: https://stackoverflow.com/questions/19245837/how-to-unbind-a-key-binding-in-sublime-text-2/37060993#37060993 and: Sublime Text 3 overriding crucial keys in my keyboard layout but noine of the advice worked for me. These posts were pretty old already, so they might not work anymore. I tried the package PackageResourceViewer, but couldn’t find the package to edit.

Does anyone know a solution?

SublimeText build: 4142.
Installed using snap.
OS: Ubuntu 22.04.1 LTS + gnome 42.5
kernel: 5.15.0-53-generic

0 Likes

#2

Have you tried safe mode?

0 Likes

#3

I didn’t know about safe mode. Tried it, it makes no difference.

0 Likes