Sublime Forum

Font size and UI scale changes at startup (Linux)



my version of Sublime 3 (3134) shows a different font size depending on whether it is opened along with a file or opened without passing a file to open. I use the Linux version under XFCE (Arch Linux), but never had this problem before.

When I double-click a (plain) text file, my system opens Sublime Text, passes the file name as a parameter, and the result looks like in the first picture. The process call is the following:

/opt/sublime_text/sublime_text /home/david/Desktop/wiki.txt

When I open Sublime Text first (without passing a file parameter), and then open the same file in Sublime Text, it will look like in the second picture. In this case, the process is called without a file as parameter.


In addition to the font size, the whole interface seems to be scaled up, e.g. the tab size.

Also, in both cases, changing the font size in the preferences and then changing it back won’t help. The font size in the second case just seems to have an »offset« of some kind. Also, when using CTRL+Scroll to change the font size, in the second case, the minimum will look bigger than in the first case.

I use Roboto Mono as the font face, but I have the same issue with any font face. Font size is 9.5. Yes, maybe a little bit weird, but even at an integer like 10, the problem persists.

“font_face”: “Roboto Mono”,
“font_size”: 9.5,

At a much bigger font size, such as 20, in the second case, the text will render still bigger than in the first case. This is why I mentioned an »offset«.

Any ideas how to solve this issue?

Thank you all,



interesting, sounds similar to this:

you can just set dpi_scale (to your preferred value) in your preferences to fix this for now



Nice, thank you very much! Indeed, adding

“dpi_scale”: 1.0

to the settings resolves the problem.

By the way, calling Sublime Text with a file parameter from the terminal also results in the scaled-up version. I don’t know what other magic XFCE does when double-clicking on a file, and couldn’t find anything on the internet so far.

Thanks again!



this setting does not work anymore in the latest version of sublime, use

"ui_scale": 2.0