Sublime Forum

Emmet snippets not working


Hi, I’m banging my head trying to figure this out. Sublime 4 on the latest MacOS 14. On my other computer MacOS 12.2.6, it works fine . If I copy/paste the exact same code from my Emmet settings file into my new install, it doesn’t.

I want to be able to type div.hello and have it output <div class="hello"></div><!-- .hello --> but I just get <div class="hello"></div>
I also can’t get it to honor special characters like it used to. E.g., "qw": "@media (orientation: landscape) {\n\t|\n}" spits out the media query code and inserts the line breaks and a tab, and sets the cursor after the tab. In the new install, it breaks.
Here’s the full code in my emmet settings:
{ "config": { "preferences": { "filter.commentAfter": "<!-- <%= attr(\"id\", \"/#\") %> <%= attr(\"class\", \"/.\") %> -->", }, "css": { "snippets": { "acsb": "align-content: space-between;", "qw": "@media (orientation: landscape) {\n\t|\n}", }, }, } }



Go to Settings > Package Settings > Emmet > Settings and enable comment option



Thank you, that worked for the closing comment!
Still don’t have the cursor placement working, but this is a huge help.