Sublime Forum

Don't open palette by {


I am just a starter. I use sublime to write latex. Sometimes I tap “{” and the command palette showed up. How can I change it?

for example, when I write my first line \documentclass{ the command palette will definitely appear.



which third party packages do you have installed? maybe the one which triggers this behavior has a setting to disable it?



It’s not a bug, it’s a feature. At least if you use LaTeXTools package, as I do. When you print \documentclass{ then it suggests possible document classes for you to choose. If you enter \ref{, it will suggest label names existing in your tex-file, if you enter \cite{ it will suggest references from your bib-file, etc, and you can then use the glorious fuzzy search to quickly find what you want. If you want to disable that, go to Preferences->Package Settings->LaTeXTools->Settings - User and try to set options that end with _auto_trigger (e.g., fill_auto_trigger) to false.

1 Like


Oh, thanks! Now I finally understand what’s going on.