Sublime Forum

Disabling zoom

#1

I typically keep a very large number of windows open. Occasionally, my finger slips and I hit the zoom shortcut. Because the zoom feature, for some reason, affects all of my windows, it takes a couple of minutes to propagate, and a couple of more to zoom back. It’s pretty disruptive, though, fortunately, a rare occurrence.

Since the global zoom behavior seems like it’s here to stay (see post from 2013: Zoom windows independently), it’d be nice to just disable it. I have no need for it. I’m probably not the only one. I’ve been using Sublime for twelve years and I’m not sure I’ve ever used it (I’m writing code, not manipulating images; I’m not sure why this feature is even present). However, I don’t see configuration to do this. Am I missing something, or am I just out of luck?

Thank you.

0 Likes

#2

My use cases for zoom are

  • being old. After 5 or 6 hours my eyes just get tired and zooming in a couple of clicks is like being on holiday
  • shared screens over Teams / whatever where other people might struggle to see depending on differing resolutions

I feel your pain though, I’ve ended up staring at a gigantic font more than once with no idea how I got there.

1 Like

#3

The behavior can be modified or disabled via Default (<Windows|Linux|OSX>).sublime-mousemap.

Just create a file appropriate for your OS in your User package and re- or unbind the scrollwheel.

As of ST 4134 it is possible to unbind via empty command "command": "".

	{ "button": "scroll_down", "modifiers": ["ctrl"], "command": "" },
	{ "button": "scroll_up", "modifiers": ["ctrl"], "command": "" },

In earlier builds you might want to bind mouse wheel to a fake command such as "command": "noop" with basically the same effect.

	{ "button": "scroll_down", "modifiers": ["ctrl"], "command": "noop" },
	{ "button": "scroll_up", "modifiers": ["ctrl"], "command": "noop" },
0 Likes

#4

I’m more concerned with the keyboard shortcut. That’s how I’m activating it (CTRL++). I forgot that you can zoom via wheel. I’ve never even accidentally activated it via mouse, probably because, I think, I’m probably most just using the keyboard (unless I’m navigating the menu).

0 Likes

#5

You may also noop the keybinding by overriding it in the corresponding file.

1 Like

#6

Confirmed. Finally, this freaking issue has been vanquished to the alternative realm [of no-op].

[
    { "keys": ["ctrl++"], "command": "noop" },
    { "keys": ["ctrl+="], "command": "noop" },
    { "keys": ["ctrl+-"], "command": "noop" }
]
0 Likes