Sublime Forum

Disable minimap preference

#1

Having gone thru the 768-line preferences file to set up Sublime 4, I find I’m still unable to disable the horrible minimap by default.

Expected:

  1. Add "minimap": false, to preferences.
  2. No minimap

But got:

  1. No such pref.
  2. Manually disable minimap on every. damned. tab.
  3. Look up forums for custom plugins to disable it.

This is the #1 blocker for me on using Sublime for anything.

0 Likes

#2

There is the option View -> Hide Minimap. As far as I can see in safe mode on ST4, that hides minimap across all tabs, all groups.

1 Like

#3

The minimap is a per-window visual effect and new windows inherit the state of it from the window that’s active when they’re created. So, if you don’t want to see the minimap you need to manually turn it off in all windows, and then it will remain off forever.

Note that the state is stored in the session/workspace file, so if you use projects you will need to turn it off in those manually when you open them, if they had the minimap displayed the last time you opened them.

0 Likes

#4

I dislike having to use StackOverflow, but this solution actually worked to provide the feature that should be there, then set “show_minimap”: false, in my preferences.

#!/usr/bin/env python3
# -*- coding: utf-8 -*-

import sublime
import sublime_plugin

class MinimapSetting(sublime_plugin.EventListener):
	def on_activated(self, view):
		show_minimap = view.settings().get("show_minimap")
		if show_minimap:
			view.window().set_minimap_visible(True)
		elif show_minimap is not None:
			view.window().set_minimap_visible(False)
0 Likes