Sublime Forum

Disable gnome titlebar

#1

Hi,

Have just upgraded to latest Merge build (love the new location filter!)

Is there a way of disabling the extra thick gnome titlebar? I’ve tried the new themed_title_bar config option but all that does it change the colour.

I’m using i3 and the gnome titlebar overrides the window manager’s titlebar.

Side note, is there a reference for the settings JSON? I checked https://www.sublimemerge.com/docs/ but could not find one.

Thanks

0 Likes

#2

You can add this setting to your Merge preferences:

    "gtk_client_side_window_decorations": false,

Once you turn the setting off, you need to restart Merge for it to take effect.

1 Like

#3

The custom titlebar should be disabled I’d you’re not using gnome. What DE are you using?

0 Likes

#4

Thank you! Solved

0 Likes

#5

i3 but using Regolith which makes i3 run well with gnome tools. That I want, just not the titlebars :wink:

0 Likes

#6

What is $XDG_CURRENT_DESKTOP set to?

0 Likes

#7

XDG_CURRENT_DESKTOP is GNOME

0 Likes

#8

That would be why it’s enabled :slight_smile:, iirc there’s no other way to easily check for the window manager.

0 Likes

#9

No trouble, I know my setup is weird :grin:

Is there a reference for these settings? I had a search but couldn’t find anything.

0 Likes

#10

I think @OdatNurd pulled that setting from the Sublime Text 4 settings files since SM & ST 4 use the same base UI framework.

0 Likes

#11

Indeed I did, but it doesn’t appear in the default settings. It’s one of a few hidden settings that are available for exceptional circumstances but which aren’t publicly documented in Sublime Text’s default Preferences.sublime-settings.

In this case it’s exceptional because Text and Merge should enable and disable this feature on their own, but as noted above it can be problematic to determine if Gnome is in use or not (also I’m in the opposite boat to you and want this enabled even though I’m not using anything Gnome related).

0 Likes