Sublime Forum

Disable automatic copy on select


How in the world can I disable the “feature” where ST will automatically add selected text to the clipboard? So many times i have a block of code from one file in the clipboard, go to another file, highlight code to delete it, and when I hit paste, I don’t get the code I copied and want to insert, but instead i get the code I just deleted. It is so incredibly frustrating and wastes so much time. Please can someone help?



Sublime doesn’t copy text on selection except on Linux, where selecting text puts it into the secondary paste buffer for pasting via a middle mouse click. As such the first thing I would check is if you have a package or plugin installed that might be doing you unexpected favours.



For future record, I found a setting that appears to do this:

// If true, the selected text will be copied into the find panel when it’s
// shown.
// On Mac, this value is overridden in the platform specific settings, so
// you’ll need to place this line in your user settings to override it.
“find_selected_text”: false

If this is true (default) AND you have find bar open, it will copy anything you select to the clipboard even in Linux. Changed this to false and that fixed the issue for me.