Sublime Forum

Console key (Ctrl-`) not working on UK keyboards?


The menu command works fine. The keyboard shortcut does nothing.

I’ve reproduced this on two machines. One is an ancient Dell server running Win2003. The other is a recent laptop running Win7 64bit (and ST2 64bit), both with the builtin keyboard and a wireless one. About the only thing the two machines have in common is a UK keyboard.

sublime.log_input(True) shows nothing at all for Ctrl-. It shows plain just fine (0x60), and Shift-(0xac), and AltGr- (0xa6), and Ctrl-c (control+c). But not Ctrl-`.

I’m pretty sure I’ve hit another ST2 feature which only worked from the menu rather than the advertised keyboard shortcut, but unfortunately can’t remember what it was.



Hmm. Seems strange.

However, as a hotfix, can’t you just remap it? Swap:

{ "keys": "ctrl+`"], "command": "show_panel", "args": {"panel": "console", "toggle": true} },


{ "keys": "ctrl+alt+c"], "command": "show_panel", "args": {"panel": "console", "toggle": true} },

for example…? Or doesn’t that work either? (It works fine for me; however, using a norwegian keyboard (that doesn’t have the `-button, so I’m kinda forced to remap it))



The default console key mapping does’t work on Norwegian keyboards either.
To use on Norwegian keyboards you press shift- (backslash key, next to backspace) and spacebar. Or whichever key you want to use ` as an accent on. à f.ex.

Anyhow, to map the console to ctrl+the key left of 1 you would have to map to ctrl+\ or ctrl+\ as it is in the config file.

Loving Sublime so far. First time user. Used UltraEdit back in the day, but lately just vim and notepad…



Oh, forgot to mention. Remapping to ctrl+\ in the config file allows you to use the equivalent of ctrl+` on a Norwegian keyboard but using ctrl+\ which you actually specify does NOT work… Go figure.



On a Spanish keyboard the default key binding din’t work. The key to the right of the number 1 is the | key, next to the backspace is the ¿ key and then the ’ key. To get the key one needs to use Ctrl+Alt+} and then the key one wants to compose with, or space for the alone. After trying several other ways to use non letter keys I ended using the ctrl+alt+c sugested keymap.

Someone can tell me why these keys can’t be used in a key mapping? I’m just starting with ST2, and there must be more commands with non working key mappings. I want to know which things to look for so i can workaround somehow.



I have run into this problem aswell oddly enough everything seems to be in the right place when you use the plain keys however the moment i try to use key combinations i find that the key is not detected at all the ' is actually detected as and the # key is actually detected as ’ . All the other seem to be in the right place.

Quite odd. So basically Ctrl+’ is actually Ctrl+` for me.

Hope it’s of any help to somebody.



This is also problem with Finnish keyboards. First I tried to map console window to Ctrl+§ but that didn’t work. Atm. I’m using Ctrl+Shift+Insert that I feel quite convenient.



That’s because \ is an escape character. Thus \ is the correct form to specify .



Same problem here with spanish keyboard :confused:



Any fix for UK keyboards? Indeed, the ctrl+` key event is simply not detected!



Not a fix, but I have to press Ctrl+’ which ST recognises as Ctrl+`

I believe this has also been discussed at



It does not works either on a French keyboard. And the character for the workaround of the last message : ’ is not on a French keyboard.