Sublime Forum

Color Scheme for code not working

#1

Sometimes Sublime Text 2 will recognize my code with its color scheme and other times it won’t. I do a lot of pasting code into the code editor and editing it, but I rarely write code in it, mostly editing my older code. Its really helpful having the color scheme!

0 Likes

#2

If you are just opening new files and pasting text in, the default syntax is “Plain Text”, thus no highlighting. You can set the syntax in the buffer by opening the command palette and searching for "Set Syntax: ". If that isn’t what is happening, please try to give more information.

0 Likes

#3

That’s exactly what happened, thanks for the help! I did “Set Syntax: HTML” I’m a noob so I’m not sure if this is correct, but it looks like what I wanted.

0 Likes

#4

You can also click the option at the bottom-right corner (where it, by default, says ‘Plain Text’) to change the syntax. There is a plug-in, I believe, that will recognise syntax; it might be called something like ‘Auto-Detect Syntax’.

0 Likes

#5

Dear Please check this At Right corner of sublime and change it to php or whatever language you have been use. it will show color accordingly Thanks…

0 Likes

#6

@agibsonsw, this helped me out. My syntax is by default set to Python. By clicking on the bottom right and changing from “Plain Text” to “Python”, I was able to get the color scheme I wanted.

1 Like

#7

The package mentioned is: AutoSetSyntax.

0 Likes

#8

Thank you! That was helpful.

0 Likes