Sublime Forum

Changing font size of the results screen


How can I alter the font size on the result screen section of the display (shown at the middle part of the above picture) without altering other font sizes used in Sublime?




Although it’s from a little ways back, the answer linked below is still the best way to achieve this particular modification. About the only thing that’s changed is that the optional method of modifying the exec command to always use the desired syntax instead of having to modify your sublime-build files could be amended to point out that OverrideAudit now has an OverideAudit: Create Override command, so using PackageResourceViewer is no longer required.



Thank you for your response. May I ask why this has to be solved in such a complicated way?



The build-system output is normally displayed with exactly the font_size set up in Preferences.sublime-settings. If it does not the followowing statement from the linked post might point to an easy solution incase you don’t need plain text to be rendered in a certain size which is different from the global settings.

I found from googling that the font of the Build Result window in ST3 is inherited from the Plain Text syntax-specific settings.


  1. Create a new view (should be of Plain Text)
  2. Open the Command Palette
  3. Run _Preferences: Settings - Syntax Specific
  4. Remove the font_size setting from the right view
  5. Save and close the file


Thanks for your interest. I must confess that I am quite new to all this many times I am constrained to follow suggestions like a parrot. For now.

In the case of your proposed steps I do not understand what I have to do to implement step 1.

I was able to do step 2 onwards but when I got to step 4 i found there was no font_size setting on the right view.

I did try to copy and paste the font_size settings from the left which was set initially to 12 to the right hand view but playing around with that number produced no visible effect… at least to me.



Yes, ST comes with some challanges for new users, so let’s try to help you out.

Settings such as the fon_size can be placed in different files in order to make them apply globally or in certain situations only (see for more information).

The idea just was it is a syntax specific setting which contains such an overriding a font size. As the build system uses Plain Text there might be a Packages/User/Plain text.sublime-settings file with such a setting.

Step 1 just asks you to create a new file (which is plain text) in order to let the command in step 3 open that Plain text.sublime-settings file. If the right pane of the settings window is empty, you’re done here. Means there is no syntax specific font size setting, which causes your issue.

Does the build system’s font size change, if you turn the mouse wheel while holding down ctrl key?



OK this is interesting (and confusing).

When I initially had gone through the 4 steps suggested by deathaxe I had skipped over step 1 but I still had my original file open. As I said previously the right hand side screen (step 4) simply consisted of an open and close brackets.

Today i closed all existing files and opened a new one. The initial text in the coding screen was the same size as that of the result screen i.e. big. I then saved the file with a .py extension after which the font size in the coding screen automatically reduced in size as before.

I then cancelled this file and started afresh but without saving. The font size was again as big as that of the result screen.

Without saving anything I went through steps 2 to 4 again but this time round the right hand screen of step 4 came up with quite a lot of code. This included a “font_size = 20” which seems to be the font size of the original screenshot I had attached. Deleting this line forced the font of both screens to 10 (the size in the left hand screen).

Reinserting “font_size” in the right hand screen and setting it to 12 changed the size in both screens, which is what I am after.

So… the question from me is…
why does this method work on a new file but not on an existing file or a file which is saved?

Did I say I am confused?:star_struck:



When you use Preferences > Settings from the menu, you get a split window with default settings on the left, and your custom settings on the right. Any settings that you add to your custom settings on the right override the ones on the left; so for example if your right file doesn’t have a font_size in it, then the one from the left hand pane is used instead.

There is a similar mechanism for file type specific settings; if you have a file open and choose Preferences > Settings - Syntax Specific you get a similar window, but now the file on the right is settings that apply to files of the particular type you’re editing. In this case the order of settings goes Defaults > User Preferences > Syntax Specific. That is, if you don’t have a font_size in the syntax specific settings, the one from your overall preference is used, and if that also doesn’t have the setting, the default is used.

New tabs with no files associated with them are Plain text files (see the bottom right of the window where file types are displayed), so the settings for plain text files will apply (if any) until you save the file with an extension that tells Sublime what type of file it is.

Build systems by default use the plain text file type to display their output, so the font size used by plain text files will also be used for build output as well.

If you want your build output to be bigger or smaller than normal text files, then something like the steps I mentioned in my original answer above are what you want (if not, apologies if I misunderstood what it was you were asking and muddied things up a bit. :smiley:). Basically what that’s doing is telling a specific build to use an alternate syntax, which allows you to provide alternate settings.

This video goes into some more depth on configuring Sublime, which has a pretty powerful and expressive system for gettings things working the way you want but which can be a bit confusing to those that are new to it:

1 Like


I am sorry but I am still not getting it. For me there is something else happening which the above comments are not explaining. Here is a simple experiment I carried out.

I created a single line program which really only contained some text preceded by “#”.
As before the Settings-Syntax Specific Preference produced a right hand user screen with lots of code including font size = 12.
Doing Cntrl+B resulted in the displayed text in the results screen having the same font as that in the code screen (probably 12)

Saving this file without a file extension did not change anything from the above.

The filename was then changed by simply adding a .py extension to the same name and then saved. Following the save, the font size in the coding screen reduced to probably size 10. The results screen remained with font size 12.
The Settings-Syntax Specific Preference produced a right hand user screen with only a pair of braces.
Same results also after a cntrl+B.

It seems to me that Sublime is recognizing the python file extension and then forcing some other conditions on the screens.



Yes, to be clear the extension on the file is what denotes the type of file that it is. Also the type of the file influences what will be used to build it when you use the build key, but that doesn’t affect the font size of the output panel; that’s always going to take the font size of whatever is used for plain text files unless you modify the sublime-build file to tell it otherwise.

A file with an unrecognized extension (including no extension) is generally plain text, while a file with an extension of .py is a Python file. So indeed changing the extension on the filename changes the type of the file, which changes what settings are used for it. This is manifested by having to font size visibly change as well as in why you see different syntax-specific settings (what you see in the right hand pane when you use Settings - Syntax specific.