Sublime Forum

Change project filename will cause not able to read


Hi, I opened my code folder and used “Save Project As” to save it as a sublime project with the name blog.sublime-project, but later on I decided to add more folders to this project. Since the name is too specific, I renamed it to web.sublime-project, then when I use “Open Project” to open web.sublime-project, it popped out this error:


So obviously, once the blog.sublime-project file was renamed, it can’t be opened anymore, why is that?, Is this a design bug or feature?

I have tried “Project > Open Recent > Clear Items” and “Project > Open Recent > Remove Deleted”, Still can’t open the web.sublime-project. Are there any other ways to use the web.sublime-project without recreating a project with those folders?


1 Like


Has anyone found a solution to this problem? I recently came across a similar issue where I renamed a project and now I get the same error and have tried the same things and cannot find any resources besides what I thought was here. Any help would be appreciated or suggestions on where to find help.



Are you sure that you opened the renamed *.sublime-project file and not the corresponding *.sublime-workspace file that references a project (and perhaps did not have the project file reference updated)?



I just open sublime text, I have a shortcut on my taskbar, but before it opens to my current projects the error pops up about the workspace. But I’m not sure how it does it. I’m gleaning that it has something to do with how sublime manages the opened projects from the last session/i.e. workspaces? The settings page is a bit daunting for me as I’m still green in my understanding of how to read code.



That could mean that it’s trying to recover a window that used to have a project loaded but can’t now that the project is done. Do you end up with an extra window or anything?



I’ve had the same issue. I had renamed a project from A to B (both, directory and sublime-project filename) and then the project could not be opened without that error popping up. Sublime has been looking at an outdated path. Its directory was correct but the filename was not.

Open Project, Switch Project, Quick Switch Project – all the same results. I am sure I was opening the sublime-project file and not the sublime-workspace one.

Removing deleted items didn’t help. Closing and reopening Sublime didn’t help.

However, what did fix it for me was to click OK on the error and “Save the project as” anew-- or, rename via the GUI, this time.

Closing and reopening the project shows no error message anymore.