Sublime Forum

Can't type symbol tilde '~' in Sublime Text

#1

Hello,
I just set up my new MacBook Pro and installed Sublime Text as every time. Just wanted to start working I realize that I can’t type ‘~’ in Sublime Text. Neither in text/code nor in searchfield. It just not showing nothing and no error. As you can see here my keyboard works fine. Every other app (TextEdit, Terminal,…) accepts ~ and works as it is supposed to.
I never had that kind of a problem and don’t know what to do. I’m using macOS 10.14.6 and Sublime Text 3.2.1 Build 3207.

0 Likes

#2

Can you try running this in the console: sublime.log_input(True);sublime.log_commands(True) and then typing ~ and see if a key event or command comes up?

2 Likes

Problem of using these characters : # |
#3

Hello bschaaf,
thank you for answering. This is the output:
key evt: alt+n
command: sbs_next_diff

I don’t really know what to do with that.

0 Likes

#4

sublime-compare-side-by-side has that keybinding.

But why typing ~ results in key evt: alt+n…?

0 Likes

#5

Oh ok, when I disable that package the ~ works again. Why is that and why it worked till now? Maybe it is worth to know that I use German language and German keyboard layout on my Mac, but this is also not new.

1 Like

#6

When a key is bound to a command it is no longer used to provide input, packages can use this to override default behavior. A German keyboard layout shouldn’t have any effect.

1 Like

#7

I got that. But I don’t know why it worked all the time and now the plugin occupied the alt+n key and how to continue using the plugin and ~ together.

0 Likes