Sublime Forum

Cannot disable autocompletion of parenthesis


When I open a new sublime session and type ‘(’ in a new window with Plain Text mode specified, it is automatically completed with an ending ‘)’. I also get this for an opening curly brace (’{’).

I have the following configuration in the Preferences.sublime file:

	"auto_complete": false,
	"auto_match_enabled ": false,
	"auto_complete_trailing_symbols": false,
	"auto_complete_selector": null,
	"auto_complete_triggers": null,
	"auto_complete_when_likely": false

Not sure what setting this could be, but it’s really annoying to have autocomplete always on when I’m in Plain Text mode. When I type one letter, I expect to get one letter in Plain Text mode. Not this.

Windows 10 Pro
Sublime build 4143



Unless you have custom keybindings overriding the default "auto_match_enabled": false disables that behavior. I suggest trying in safe mode.



Just tried it in safe mode, still have the same issue when I set auto_match_enabled: false.

Confirmed no key bindings or packages were loaded in safe-mode.



Tried it again, this time

  1. Moving files from Installed Packages to a new folder named Disabled Packages
  2. Renaming Packages to _Packages

Opened a new session, went to Preferences -> Settings and added the auto_match_enabled: false line, saved the config, and it still seems to autocomplete parens, braces, etc.



Here it is working as expected with "auto_match_enabled": false.

1 Like


Tried it again in safe mode yesterday and it seems to be behaving correctly. Will try uninstalling plugins one at a time today to see which one is the offender. Thanks for your help on this.



Despite deleting all packages and the two unrelated key bindings, I was still getting the same behavior.

After doing the following:

  1. Move Sublime Text directory out of AppData\Roaming
  2. Move Sublime Text directory out of AppData\Local
  3. Set "auto_match_enabled: false"

The editor was not auto-matching parens as expected.