Sublime Forum

Bug in column-select when word-wrap enabled



I am using 20100413 beta. This has likely always been an issue, but I just noticed it.

If I have word-wrap enabled and do a column selection, it selects the wrapped text, even though it isn’t truly in the column that I want. Can this be fixed?


1 Like


I just noticed the bug.
A quick workaround is to toggle word wrapping off through command palette for example, but it would be nice to have column selection behaving the same way wether word wrap is activated or not.



This is by design, the alternative would be a worse user experience. I can only suggest temporarily turning off word wrapping.



if “word wrap” is selected or not, it should be kept for the rest options…
For me and as i see for many users if a sublime file is “word wrapped” (default option) which şs normal, but when convert to any syntax by view menu, the “word wrapped” property gone and i need to convert/make it “word wrapped” again… whereas i think it should continue ot be the same format;
-if its “word wrapped”, “word wrapped” should be keep.
-if its NOT “word wrapped”, this time it should be keep.



The "auto" word wrap setting ("word_wrap": "auto" is the default) will use word wrapping for text documents and won’t use it for source code. If you want to change the default to true or false you can do so in your settings.
If you have already changed the word-wrap settings for a file, that will persist when you change the syntax.