Sublime Forum

Auto-complete not working


I have installed version 3.2.2 but for some reason I cannot get auto complete to work. I have looked in settings and default is “true”, there are no overrides set. I am using a Mac with High Sierra and can’t upgrade from that as the machine is toooooo old. any suggestions please



Could you please describe some steps for reproduction, what happens and what you expect to happen instead?



i start typing eg and hit tab but no autocomplete. I have tried hitting enter, space bar, and a few other keys (cmd, alt) but cannot get it to work.



this may mean that auto completion popup appears. Can you please confirm?



Hi, I get no pop-up or drop-down menu. I have already tried re-installing the software but it didn’t help



Can you provide details like the type of file that you’re trying to edit, and what you expect might appear in the autocomplete popup when nothing appears? For example in a plain text file autocomplete won’t trigger unless you specifically modify settings, and some things (such as the html snippet that expands to a page template) only work in certain kinds of files.



plus expected outcome from



Maybe OP is talking about the Mac’s system-level Text Replacements (configured at SystemPreferences > Keyboard > Text). Is a default there to turn eg without dots to e.g.?



I am creating from the start, a blank form



typing for example and hitting tab, expected autocomplete with



When you create a new tab and start typing, the file type is Plain Text (visible in the bottom right of the window). The autocomplete panel won’t automatically pop up while typing in a Plain Text file unless you modify your settings; this is because in a plain text file the only completions available are generally just other words in the file, which is more of a nuisance than a help in a lot of cases.

For example, you can try creating a new blank tab and then typing loremTab. That would expand out to a paragraph of lorem ipsum text (via a snippet):

Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod
tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam,
quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo
consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse
cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non
proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

With that in the buffer you can manually open the autocomplete panel with Ctrl+Space and you’re prompted with a list of words; if you type some text before you press the key, the completions will be tailored to the text you entered.

It’s unclear what you meant here; it looks like perhaps you had something like a <tag> or something in there that isn’t in a code block so the forum ate it.



Thanks, resolved :slight_smile: