Sublime Forum

Sublime Text window broken after crash



After Sublime Text 2 crashed its windows remain unusable and look like this: … 718babfbd1

PS. I’m quite disappointed to see there is no direct support for paid versions, just forum.



I’ve tracked the issue down to some updates. I managed to restore ~/Library/Application Support/Sublime Text 2/ from backup and it works fine, but something (plugin?) gets updated (unless I block network connection) and then the editor is broken after restart.
How can I pinpoint the issue?

I’ve also noticed a >300MB pile of backup data in the Backup folder…



I’m having the exact same problem. Although this didn’t happen after a crash, it happened after some automatic update of a plugin I think. Have no idea which one, but, now Sublime Text is all messed up and I have no idea how to fix it. I tried re-installing, but, the problem is still there.




That’s for sure happens after plugin update! It still happens today. The only remedy so far is to block ST2 from connecting to the Internet so the plugins doesn’t get updated! Anyone? I’m starting to regret I’ve paid for this software.



This is happening for me too, I’m on Win 64. I did notice what appeared to be a Package Control update but that doesn’t sense since isn’t Package Control the one liner you just paste into Py console? When it first crashed it gave me some issue about “ignored package ignoring itself, please remove…”. I wasn’t clear what it was so I tried restarting and now its not working at all. The window fails to load and I have to kill the process.



Somehow ST had corrupted the file system under AppData for me. It happened at my work computer, but not at my home (which has the identical set of plugins). For now this means I have to uninstall ST at work. Not cool :frowning:. Wish I knew what happened, but I don’t have time to track it down. I recovered the directory but I’d rather not deal with this kind of stuff.



Perhaps this problem is a side-effect of a package control bug which disabled installed packages, including any custom theme you might have installed. I saw something similar a few weeks back and use the Soda theme.

Check the following:

  1. “ignored_packages” in your user settings file. In the settings same file, “theme” refers to the theme you have installed.
  2. If the “theme” you’re using was installed through package control, and is now in the “ignored_packages” list, you’ll see sublime mess up just like in the OP’s bitmap

If the above is the case, just remove the theme package from “ignored_packages”, save and restart sublime.

If this doesn’t work, go back to the default Sublime theme simply by deleting the “theme” key.



I had the same problem. The suggestion above worked for me. In “Settings - User”, mysteriously a bunch of packages I regularly use, including the theme, were added. I set “ignored_packages” back to the default (i.e. Vintage only), and the display corruption was fixed.