Sublime Forum

Sublime Text is really laggy all of a sudden

#1

I restarted my computer this morning and re-opened ST3. Now there’s a solid 1 second delay between keystrokes and letters appearing on screen. I subsequently upgraded to 3170 through apt-get but that didn’t resolve the issue. I did notice that it looked like a package had updated when I rebooted (I want to say it was SublimeLinter), but I can’t find a package history anywhere to check what it was. Nevertheless, I’ve tried removing nearly all packages, yet the delay persists. I have been using Sublime for almost 2 years with no issue.

I’ve also uninstalled Sublime completely, deleted the .config folders as well (which do not get removed with an apt remove call), and re-installed fresh using apt install, but I’m still seeing the lag.

I am using this on Ubuntu 16.04 with 4 Intel i5 cores and 8GB of RAM. I’ve restarted at least 4 times, and have run just ST3.1 with no other programs running as well. I’d be shocked if this were a memory or computational power issue.

How can I fix this? It’s a huge disruption.

0 Likes

#2

Is your machine reindexing your codebase with the new syntax definitions? Check the Help > Indexing Status to see if that is going on.

0 Likes

#3

Hi,

I’am also using Ubuntu 16.04.

After the update I had some lags. I reset the whole config (deleted .config/sublime-text-3). I have reinstalled the plugins I use, but the lag was still there ( even without the config using a full config reset )

I checked Tools -> Developer -> Profile Plugins and have seen every plugin is in ms range exept for on_hover 15.808s total, mean: 0.025s, max: 7.877s

So I switched of on_hover functionality ( I do not use it anyway ) adding the following to my config:

{
“show_definitions”: false
}

Since I’ve done that, everything works as before. No had no more lags up to now.

Could you please check if you have something similar? Profile the plugins and check the values.

Here are mine:

This list shows how much time each plugin has taken to respond to each event:

on_activated:
Default.pane: 0.008s total, mean: 0.000s, max: 0.000s
on_close:
Default.settings: 0.001s total, mean: 0.001s, max: 0.001s
Default.pane: 0.001s total, mean: 0.000s, max: 0.000s
on_deactivated:
Default.history_list: 0.124s total, mean: 0.000s, max: 0.003s
on_hover:
Default.symbol: 15.808s total, mean: 0.025s, max: 7.877s
on_load:
Default.detect_indentation: 0.063s total, mean: 0.002s, max: 0.005s
Default.exec: 0.014s total, mean: 0.000s, max: 0.011s
on_modified:
Default.settings: 0.006s total, mean: 0.000s, max: 0.000s
on_pre_close:
Default.history_list: 0.009s total, mean: 0.000s, max: 0.001s
Default.settings: 0.001s total, mean: 0.000s, max: 0.000s
on_pre_save:
Default.trim_trailing_white_space: 0.045s total, mean: 0.000s, max: 0.000s

1 Like

#4

Hmm. Will they fix this issue? I do use on_hover functionality often.
Edit: actually “show_definitions”: false didn’t even fix it for me… Still lags.

0 Likes

#5

Just FYI I’m getting this issue too. Sorry I don’t have much time to help pinpointing the issue right now, but thought I’d chuck in my 2c.

Happens maybe 4-5 times an hour?

MacOS High Sierra touchbar Macbook pro

on_hover:
Default.symbol: 155.130s total, mean: 0.015s, max: 9.434s

1 Like