Sublime Forum

No Git documentation or add--interactive


Since Sublime Merge (allegedly) uses real Git, I tried running git add -i (in Cygwin terminal on Windows 10, after adding %PROGRAMFILES%\Sublime Merge\Git\mingw64\share\bin to my system PATH) and got the following error:

git: 'add--interactive' is not a git command. See 'get --help'.

So then I tried git help add, which brought up another error:

fatal: 'C:/Program Files/Sublime Merge/Git/mingw64/share/doc/git-doc': not a doc
umentation directory.

I checked the location specified and found that the doc directory didn’t actually contain a git-doc directory at all. So finally I downloaded the portable archive of Git & extracted the contents of the Documentation folder to a new git-doc folder in the right location, but that also didn’t fix the issue.

What am I doing wrong here? I’ve done some cursory searches and learned that interactive add not existing may have to do with Git missing its Perl scripts, but why are these and the help pages even missing? Is this by design? Is the only way to solve this to install a full version of Git separately?



Hi @NeueDarshan,

Thanks for your interest in Sublime Merge!

Sublime Merge ships with a minimal installation of Git for Windows (designed for application integration). If you’re planning on using Git from the command line, it’s suggested you download the consumer version of Git for Windows available here:



SublimeMerge with git-svn is amazing ! Need a bit more support

All right, I’ve installed Git for Windows on MinGW64 with MSYS2. Thanks for the reply.