Sublime Forum

Line break problem: period separated from word


Hi all,

I normally use Sublime Text 1.4 for writing prose and everything works fine. I bought the registration a year ago and as registration is also valid for Sublime Text 2 I thought I will give also ST2 a try now. In the last days I fiddled around with ST 2 to tweak it for my purposes, experimented with settings and everything seemed to work. But then I encountered something strange: if a word plus period don’t fit in at the end of the line, they will normally be placed at the beginning of the next line. But my problem is that period will be separated from the word, thus periods are placed in the beginning of following line while the word remains at the previous line.

Even stranger: this don’t happen with comma, semicolon, exclamation mark/point, question mark. With this punctuation marks it works absolutely normal.

Well, I’m not sure, but maybe this began after I yesterday tried out some installation packages. Not sure about that, but in the last days I didn’t notice that problem and I spent hours with ST2.

I reinstalled ST2 as I thought this could help, of course I deleted all ST2 files in %appdata% before reinstalling; but it didn’t help. It’s really strange. The problem is still there. I have never encountered such a problem in Sublime Text 1.4.

Has someone of you an idea what I could do to solve this problem?

Many greetz


Sublime Text wins the Net Awards 2014 — App of the year

That is just how the automatic word wrapping works. From this comment from Jon, it probably won’t change until Sublime Text 3.



Hello Sapphirehamster,

thank you very very much for your answer! As I am absolutely no coder, I seldomly read in the sublime forum so I didn’t have the slightest clue of this behaviour of automatic wrapping (but still strange to me that I’ve worked 2-3 days with ST2 without having noticed it!).

Well, good to have this information, otherwise I would have been fiddling around with this problem for days :mrgreen: :smiley:

Then I will work again with Sublime Text 1.4 and wait for Sublime 3 …

Thanks a lot and greetz