Sublime Forum

Dev Build 2054


Dev Build 2054 is out now. Smooth scrolling is enabled again - I’d be interested in knowing if anyone who was having issues with it previously still does.

Spell checking is also in for this version (F6 to enable). While I’ve moved onto Hunspell (from its predecessor Myspell in 1.4), non-ascii languages aren’t properly supported, as dictionaries are assumed to be UTF-8, while in reality they’re generally encoded in a language specific manner. Also, while words can be ignored, they can’t yet be added to the dictionary.

Startup time has received a small boost via removing some file IO at startup (2052 also had some improved IO scheduling at startup) - let me know if you’re getting a visible benefit from this.



It’s very smooth on gotoline. My mousewheel feels kind of sluggish when just scrolling. I’m using a Dell Vostro (Alps) trackpad.



Thanks Jon for this new release.

Smooth scrolling is fine now, even with the mouse wheel (Standard wired Dell mouse).

The only strange behavior I’ve noticed is on the Goto Symbol or Goto Word panel:
-The focus is not on the right place when the panel open (highlighted item not in the visible part)
-When you navigate with up/down arrows sometimes when you go downward the window scroll upward. A little bit strange but not a big issue.



I reported few problems with previous scrolling and this build seems to have fixed all of them. Thanks.



Everything I’ve used seems to have worked well so far Jon :smile:



No problems with smooth scrolling on my end, works perfect!

Also, I’ve dug up some things involving that odd font rendering issue. From what I can tell it’s fixed now, though I don’t think it was anything in this version that fixed it as I managed to fix it in 2053 as well after playing around with what I discovered.

It seems to be tied to tmLanguage.cache files and having an updated version of an official package in the user packages directory without deleting the official package.

I updated the PHP syntax and made a personal (valid) update and instead of overwriting the official package in /Packages I just stuck it in a PHP folder in /Packages/User. Now I knew there were some quirks with this as in view > syntax there are 2 PHP entries and when a PHP file is open they are both checked, but I didn’t want to overwrite the official package and have my update get overwritten at some point.

I tracked the character rendering glitch down to seemingly random characters at first. Before that the only thing I could ever track down as the cause was having a background color for comments set in a theme.

I ended up deleting both cache files the one in /Packages/PHP and in /Packages/User/PHP, and then moved the user PHP package to a temporary location where Sublime wouldn’t touch it. I launched Sublime, the bug was still there. I deleted the cache file again, closed and relaunched a few times and the issue was fixed. Then I copied the user PHP package back, launched Sublime and the issue was still fixed. I also verified that it wasn’t something with the user PHP package as I moved the official PHP package to a temporary location and did the same things above when I had moved the user PHP package and it then worked fine as well.

It seems to come down to some quirks from putting an updated language syntax in the user packages directory without deleting the official package and the resulting .tmLanguage.cache files.

Sorry for that being a bunch of mess, but I have no idea what exactly fixed it so I figured I’d just describe everything I did and maybe it would help track down what was causing the issue.



Yay! Thanks Jon!

Great that it still works the same way as previous version.

+it’s really easy to see the spelling errors in red with squiggly underline - unlike ‘selected search result’ highlighting - see: would be great to get that improved :wink:



Smooth scrolling is cool, but I wish it wasn’t active in the Goto overlay. I use Goto File all the time with hundreds of files in the list, and the constant variable-speed scrolling that takes place while I type in the characters needed to find the file I want to open is quite disturbing. So I’d prefer to disable it for the overlays but keep it for regular scrolling. It would be great if that was possible.



Started up Sublime again today and it started happening again. Replaced the official PHP package with the updated package. Changed file permissions on the HTML and PHP packages so Sublime couldn’t create cache files for them. Deleted my session file in Settings. Started Sublime. Opened a PHP file with doc blocks. Closed and opened Sublime repeatedly and found that it was random whether the glitch would happen or not. Got the same behavior with the official PHP package as well.



In OS X I can no longer open the preferences from the menu—Sublime Text 2>Preferences is grayed out. I’m not sure when this started happening but I just noticed it.



Did you ever find a solution to this problem? I posted a thread about it and haven’t heard anything back.



The most likely scenario is that you’ve installed a plugin that has hijacked the open_file command. For anyone else with a similar issue, will fix it.