Sublime Forum

CodeIntel ported from Open Komodo Editor


@sublimator, that was an old problem… please pull the latest from github :wink:

@senzo you too, try the latest and let me know… post log files too plz :smiley:



@sublimator no, pull should do it… however that error is an old one (fixed in github’s master)… the line numbers marked don’t even contain that code anymore (check the file online at github)… actually simply “git pull” should do it…



I’m not able to get anything working with any JavaScript libraries. Just seems to index forever (with 100% CPU usage).



So it finally finished, however I’m not sure where it has scanned. It seems to have scanned the whole HD…

Where is the indexed content stored?



It is still not working with javascript for me. You can try it out if you download the dojotoolkit from here: …
Create an empty ST2 project, put the dojotoolkit in the project folder, open any .js file and type 'dojo.(ctrl + space)"

And another point besides the scanning of .js files: There is a dojo.cix file in /SublimeCodeIntel/libs/codeintel2/catalogs/dojo.cix
So there is no need to scan the dojotoolkit folder at all - the project specific files have to scanned of course. I am not sure how this can be achieved, maybe by excluding directories manually?



I’ve this error under Ubuntu 11.04 x86_64 kernel 2.6.38-10-generic =(

Traceback (most recent call last): File ".\logging\", line 768, in emit File ".\logging\", line 648, in format File ".\logging\", line 436, in format File ".\logging\", line 306, in getMessage UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 23: ordinal not in range(128)



I added a screencast at Jing for showing the features off:

EDIT: sorry… new to screencast, posted the wrong URL :stuck_out_tongue:



@sublimator, Indeed there’s great stuff in OpenKomodo. They also have linting stuff… but I’m now using SublimeLint…

@xavi, that seems like an encoding problem… but it doesn’t seem to come directly from SublimeCodeIntel… it’s a weird traceback :S
Does your source code contains special characters?

@senzo, I can see the problem occurring here (for dojo) …but I can’t find out what it is… the dojo CIX library included with SublimeCodeIntel is for dojo 1.5 and your link is for 1.6. I’m not sure if that can be the cause or if it’s something else…

Always pull the latest SublimeCodeIntel… and if anyone is experiencing issues or problems running SublimeCodeIntel in any platform, please let me know at :smile:



Howdy! I’m trying to try out CodeIntel, but for some reason, it is trying to load the OS X versions of the prebuilt libraries and subsequently the CodeIntel plugin fails to initialize. I’m on an up-to-date Arch Linux x86-64 system, using the latest Sublime build and my copy of CodeIntel is at the latest commit (71cf6ae as of this writing). Here is the relevant bit of the log log from the Sublime console:

Reloading plugin /home/nerdshark/.config/sublime-text-2/Packages/SublimeCodeIntel/
Traceback (most recent call last):
  File "./", line 29, in reload_plugin
  File "./", line 86, in <module>
    from codeintel2.common import *
  File "/home/nerdshark/.config/sublime-text-2/Packages/SublimeCodeIntel/libs/codeintel2/", line 76, in <module>
    import SilverCity
  File "/home/nerdshark/.config/sublime-text-2/Packages/SublimeCodeIntel/libs/SilverCity/", line 1, in <module>
    import _SilverCity
  File "/home/nerdshark/.config/sublime-text-2/Packages/SublimeCodeIntel/libs/SilverCity/", line 22, in <module>
    from _macosx_universal._SilverCity import *
ImportError: /home/nerdshark/.config/sublime-text-2/Packages/SublimeCodeIntel/libs/_macosx_universal/ invalid ELF header

I’m really excited to get this working, as I’ll be able to switch from my comparatively uncomfortable gvim config!


Edit: After hacking on SublimeCodeIntel/libs/SilverCity/ and allowing the ImportError to be raised on import of the linux x86_64 libs, I discovered that something was trying to load a version of the pcre shared library that didn’t exist on my system.

Reloading plugin /home/nerdshark/.config/sublime-text-2/Packages/SublimeCodeIntel/ Traceback (most recent call last): File "./", line 29, in reload_plugin File "./", line 86, in <module> from codeintel2.common import * File "/home/nerdshark/.config/sublime-text-2/Packages/SublimeCodeIntel/libs/codeintel2/", line 76, in <module> import SilverCity File "/home/nerdshark/.config/sublime-text-2/Packages/SublimeCodeIntel/libs/SilverCity/", line 1, in <module> import _SilverCity File "/home/nerdshark/.config/sublime-text-2/Packages/SublimeCodeIntel/libs/SilverCity/", line 10, in <module> from _linux_libcpp6_x86_64._SilverCity import * ImportError: cannot open shared object file: No such file or directory

Creating a symlink from /usr/lib/ to /usr/lib/ gets CodeIntel to load. Now, the question is, why is CodeIntel linking to a specific version of pcre? Wouldn’t it be better to link to the copy of the library that doesn’t have the version in its filename?



@nerdshark, the problem here is the pre-built linux binaries aren’t compatible again… I’m not sure if Jon changed something and that’s the reason or if your Linux is causing the problems :frowning:

I’ll ask Jon to see if he changed anything (since he built the Linux and windows binaries for me). I wish Linux would use a standard python distribution as these problems would be reduced… In exchang for a couple extra megabytes at the most, I would think.



@nerdshark, Jon just hinted me about what the problem is… it seems it’d be fixed if you install libpcre… since it’s a dependency at the moment.



I DO have it installed. The problem is that it looks for a specific version of pcre (, rather than one without the version in the filename ( Changing that should make everything hunky-dory.



@nerdshark, could you try making a symbolic link called to or whatever version you have (hopefuly it’ll work)… and please, let me know if it does work. :smile:



Yes, I tried that and it works. Created the symlink from /usr/lib/ to /usr/lib/ fixes the issue. Now all that needs to be fixed is how the library is being built so that it links against rather than



This seems to work on/off for me (javascript). Is there anyway I can debug with logs or something?



Dude. Using standart hotkeys is not good. Like <super + j> macos. I’m using it every day and I have to delete it from your plugin after every update. It’s annoying a bit. Can you do something with it?

btw, Can you share your theme for st2 and for autocomplete window from screencast, please? :smile:



@squ1b3r, I got that super+j from the Komodo Editor, that’s the same key they use for showing the autocomplete… but we could all vote and find better key bindings (I already changed the cmd+click to alt+click for compatibility issues in ST2 too)…

The current bindings are:
cmd + j = Show CodeIntel autocomplete popup
cmd + f3 = Jump to symbol definition
alt + click = Jump to symbol definition

  • for windows and linux, the above “cmd” = “ctrl”

Regarding the color theme in the screencast, it’s based in the RailsCasts theme, and modified a bit. About the background in the autocomplete, I’m using Soda Dark theme ( I’m attaching it here for anyone who wants it :smile:

@rdougan, the logs currently are at ~/.codeintel/codeintel.log …what do you mean “on/off” ? (1.99 KB)



@Kronuz thanks man!




I’ve managed to get it working fairly well now with all your latest updates. Thank you.

Few questions:

  • Is it possible to tell it NOT to automatically scan all the files, or perhaps give it an ignore.json or something similar?
  • Can I give it a JSON file of all the available methods and their scopes? (can’t find any documentation on CodeIntel)


I have a small problem with codeintel. Take a look here.
The thing is: i write something, the completion appear and if i continue to type something that is not in the suggested list will insert the first suggestion. Is also happen on html files.

Did i do anything wrong?