Sublime Forum

Autocompletion now 2 steps

#1

When I typed div and pressed TAB Sublime Text used to immediately type out <div>|</div>. Now there’s a dropdown that appears when I press TAB which requires me to then press ENTER to complete the tag.

12%20PM

I don’t like this, is there any way to go back to the old way where the autocomplete worked after pressing TAB without this extra step?

I’m using ST4.

0 Likes

Making Tab completion in ST4 like ST3
#2

In ST4 autocomplete properly respects the "auto_complete_selector" setting and such doesn’t activate automatically inside regular html. Typing a < will enable auto-complete, though you can also change the setting to have it always enabled inside html.

0 Likes

#3

In ST4 autocomplete properly respects the "auto_complete_selector" setting and such doesn’t activate automatically inside regular html.

Isn’t "auto_complete_selector" supposed to control where the autocomplete popup should automatically trigger while typing? This worked the same for me in ST3 and didn’t activate inside regular HTML.

Typing a < will enable auto-complete, though you can also change the setting to have it always enabled inside html.

I think this is not what the OP tries to achieve. They want to insert the completion with a single keypress and without displaying the autocompletion popup first. This used to be what the "tab_completion" setting controlled. This setting is still present in ST4 and with the same description, but it doesn’t seem to work anymore (at least it doesn’t do what it describes).

        // When enabled, pressing tab will insert the best matching completion.
	// When disabled, tab will only trigger snippets or insert a tab.
	// Shift+tab can be used to insert an explicit tab when tab_completion is
	// enabled.
	"tab_completion": true,

Adding text.html to the "auto_complete_selector" would constantly trigger the popup when typing normal text, so this would be very annoying.

1 Like

#4

I makes no sense that ST4 presents a popup when there is only one option for the completion, as shown in the original message I posted above. div only shows one option in the dropdown, yet it still requires two key presses to autocomplete it.

Autocomplete is a REALLY IMPORTANT tool for coding, and this new way that ST4 works only slows things down and makes using the editor so cumbersome. I use ST4 nearly every day (I paid for the new ST4 license) and I’m seriously considering downgrading to ST3 because this is supremely annoying and I’m getting sick of it.

So far I’ve see no official response from the ST team about all the complaints, this is clearly a very unwelcome “feature” of ST4 and deserves to be addressed. If they are working on a fix, let us know please.

1 Like

#5

Hi, I know your frustration. Luckily the community solved that problem. Check out this plugin made by @LightsOut8008 and @Suor.

0 Likes

#6

I downgraded to the latest Sublime 3 version since day one after trying ST4. I don’t like it at all and as you said it only slows me down. Whenever I type something in CSS in front of another property it inserts me a ; which is so annoying. And the popup you mentioned it doesn’t make any sense, since I could simply press CTRL+SPACE if I wanted more autocomplete options, like I do on ST3.

0 Likes

#7

I’m certainly not a CSS expert, but shouldn’t you have one property per line? Can you give an example of what the undesired behavior is?

Note that you can “jump over” semicolons by pressing the semicolon on your keyboard.

0 Likes