Sublime Forum

4107 __init__() got an unexpected keyword argument 'kill_previous'


After upgrade to ST4 (4106 and 4107) any attempt to build anything results in this error:
__init__() got an unexpected keyword argument 'kill_previous'

Any hints about what to do?

I guess it’s bad package based on previous similar issues in the past but haven’t been able to identify a rogue package as yet.



Do you by any chance have a folder in your Packages directory called Default having a file ? It is probable that the upgraded build systems are using an outdated version of because it is an override.



Remove the Default folder in your Packages folder if you don’t know what you’re doing.



Thanks so much. You have saved me what I imagine would have been hours of debugging.



Should I just delete ? or… :thinking:



As @rwols said, if you did not know how it got there, just delete it. You should not create an override without not knowing what it does.



I have the same problem after updating to the latest version. But i don’t have the default package, only the package file Default.sublime-package. It still doesn’t work if i delete it.



Are you looking in the correct location? The Packages folder that you’re looking at here is the package files that ship with Sublime Text in it’s installation folder, and is entirely a hands off kind of location (i.e. if you deleted your Default.sublime-package file from here, you’re crippling Sublime).

The Packages folder you want to be looking at is the one that you get to by using Preferences: Browse Packages from the menu or the command palette. If there’s a folder there named Default, then the contents of it are overriding what appears in the package in your screenshot.

And in particular, in Sublime Text 3 the exec command took different arguments than it does now, so the error message you’re seeing here is an indication that this folder has an in it that’s getting angry about the new argument that it’s being provided.

Generally speaking, you want to take that Default folder (if it exists) and move it away to your Desktop and restart Sublime; any files in there are almost certainly causing you woes as there have been major updates to this version of Sublime, and any files in there are masking some of them.

1 Like


@OdatNurd, thank you so much for the details! I didn’t find the correct location. Now it works!! :smile: